Merge branch 'next' into mate

This commit is contained in:
Nedko Arnaudov 2023-06-10 18:27:40 +03:00
commit 3cf98a9553
5 changed files with 437 additions and 0 deletions

View File

@ -0,0 +1,301 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Be careful with packaging odd-version-number branches.
# See https://www.freedesktop.org/wiki/Software/dbus/#download.
PYTHON_COMPAT=( python3_{10..12} )
TMPFILES_OPTIONAL=1
# From 1.15.0 release notes:
# "• Add a Meson build system. This is currently considered experimental,
# but the intention is for it to replace Autotools and/or CMake in future
# releases, preferably both. Please test!"
# We haven't migrated to it yet as it's experimental but our elogind
# patch needs adjusting too (and upstreaming, ideally!)
# https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/NEWS#L31
inherit autotools flag-o-matic linux-info python-any-r1 readme.gentoo-r1 systemd tmpfiles virtualx multilib-minimal git-r3
EGIT_REPO_URI="https://github.com/LADI/dbus.git"
EGIT_BRANCH="ladi-dbus-1.15"
DESCRIPTION="A message bus system (LADI project modifications)"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/dbus/ https://gitea.ladish.org/LADI/dbus/"
#SRC_URI="https://dbus.freedesktop.org/releases/dbus/${P}.tar.xz"
LICENSE="|| ( AFL-2.1 GPL-2 )"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="debug doc elogind selinux static-libs systemd test valgrind X"
RESTRICT="!test? ( test )"
REQUIRED_USE="?? ( elogind systemd )"
BDEPEND="
acct-user/messagebus
app-text/xmlto
app-text/docbook-xml-dtd:4.4
sys-devel/autoconf-archive
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
COMMON_DEPEND="
>=dev-libs/expat-2.1.0
elogind? ( sys-auth/elogind )
selinux? (
sys-process/audit
sys-libs/libselinux
)
systemd? ( sys-apps/systemd:0= )
X? (
x11-libs/libX11
x11-libs/libXt
)
"
DEPEND="${COMMON_DEPEND}
dev-libs/expat
test? (
${PYTHON_DEPS}
>=dev-libs/glib-2.40:2
)
valgrind? ( >=dev-util/valgrind-3.6 )
X? ( x11-base/xorg-proto )
"
RDEPEND="${COMMON_DEPEND}
acct-user/messagebus
selinux? ( sec-policy/selinux-dbus )
systemd? ( virtual/tmpfiles )
"
DOC_CONTENTS="
Some applications require a session bus in addition to the system
bus. Please see \`man dbus-launch\` for more information.
"
# out of sources build dir for make check
TBD="${WORKDIR}/${P}-tests-build"
PATCHES=(
"${FILESDIR}/dbus-1.15.0-daemon-optional.patch" # bug #653136
)
pkg_setup() {
use test && python-any-r1_pkg_setup
if use kernel_linux; then
CONFIG_CHECK="~EPOLL"
linux-info_pkg_setup
fi
}
src_prepare() {
default
if [[ ${CHOST} == *-solaris* ]]; then
# fix standards conflict, due to gcc being c99 by default nowadays
sed -i \
-e 's/_XOPEN_SOURCE=500/_XOPEN_SOURCE=600/' \
configure.ac || die
fi
# required for bug #263909, cross-compile so don't remove eautoreconf
eautoreconf
}
src_configure() {
local rundir=$(usex kernel_linux /run /var/run)
sed -e "s;@rundir@;${EPREFIX}${rundir};g" "${FILESDIR}"/dbus.initd.in \
> "${T}"/dbus.initd || die
multilib-minimal_src_configure
}
multilib_src_configure() {
local docconf myconf testconf
# so we can get backtraces from apps
case ${CHOST} in
*-mingw*)
# error: unrecognized command line option '-rdynamic', bug #488036
;;
*)
append-flags -rdynamic
;;
esac
# libaudit is *only* used in DBus wrt SELinux support, so disable it, if
# not on an SELinux profile.
myconf=(
--localstatedir="${EPREFIX}/var"
--runstatedir="${EPREFIX}${rundir}"
$(use_enable static-libs static)
$(use_enable debug verbose-mode)
--disable-asserts
--disable-checks
$(use_enable selinux)
$(use_enable selinux libaudit)
--disable-apparmor
$(use_enable kernel_linux inotify)
--disable-kqueue
$(use_enable elogind)
$(use_enable systemd)
$(use_enable systemd user-session)
--disable-embedded-tests
--disable-modular-tests
$(use_enable debug stats)
--with-session-socket-dir="${EPREFIX}"/tmp
--with-system-pid-file="${EPREFIX}${rundir}"/dbus.pid
--with-system-socket="${EPREFIX}${rundir}"/dbus/system_bus_socket
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
--with-systemduserunitdir="$(systemd_get_userunitdir)"
--with-dbus-user=messagebus
$(multilib_native_use_with valgrind)
$(use_with X x)
)
if [[ ${CHOST} == *-darwin* ]]; then
myconf+=(
--enable-launchd
--with-launchd-agent-dir="${EPREFIX}"/Library/LaunchAgents
)
fi
if multilib_is_native_abi; then
docconf=(
--enable-xml-docs
$(use_enable doc doxygen-docs)
)
else
docconf=(
--disable-xml-docs
--disable-doxygen-docs
)
myconf+=(
--disable-daemon
--disable-selinux
--disable-libaudit
--disable-elogind
--disable-systemd
--without-x
)
fi
einfo "Running configure in ${BUILD_DIR}"
ECONF_SOURCE="${S}" econf "${myconf[@]}" "${docconf[@]}"
if multilib_is_native_abi && use test; then
mkdir "${TBD}" || die
cd "${TBD}" || die
testconf=(
$(use_enable test asserts)
$(use_enable test checks)
$(use_enable test embedded-tests)
$(use_enable test stats)
$(has_version dev-libs/dbus-glib && echo --enable-modular-tests)
)
einfo "Running configure in ${TBD}"
ECONF_SOURCE="${S}" econf "${myconf[@]}" "${testconf[@]}"
fi
}
multilib_src_compile() {
if multilib_is_native_abi; then
# After the compile, it uses a selinuxfs interface to
# check if the SELinux policy has the right support
use selinux && addwrite /selinux/access
einfo "Running make in ${BUILD_DIR}"
emake
if use test; then
einfo "Running make in ${TBD}"
emake -C "${TBD}"
fi
else
emake -C dbus libdbus-1.la
fi
}
src_test() {
# DBUS_TEST_MALLOC_FAILURES=0 to avoid huge test logs
# https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/CONTRIBUTING.md#L231
DBUS_TEST_MALLOC_FAILURES=0 DBUS_VERBOSE=1 virtx emake -j1 -C "${TBD}" check
}
multilib_src_install() {
if multilib_is_native_abi; then
emake DESTDIR="${D}" install
else
emake DESTDIR="${D}" install-pkgconfigDATA install-cmakeconfigDATA
emake DESTDIR="${D}" -C dbus \
install-libLTLIBRARIES install-dbusincludeHEADERS \
install-nodist_dbusarchincludeHEADERS
fi
}
multilib_src_install_all() {
newinitd "${T}"/dbus.initd dbus
if use X; then
# dbus X session script (bug #77504)
# turns out to only work for GDM (and startx). has been merged into
# other desktop (kdm and such scripts)
exeinto /etc/X11/xinit/xinitrc.d
newexe "${FILESDIR}"/80-dbus-r1 80-dbus
fi
# Needs to exist for dbus sessions to launch
keepdir /usr/share/dbus-1/services
keepdir /etc/dbus-1/{session,system}.d
# machine-id symlink from pkg_postinst()
keepdir /var/lib/dbus
# Let the init script create the /var/run/dbus directory
rm -rf "${ED}"/{,var/}run
# bug #761763
rm -rf "${ED}"/usr/lib/sysusers.d
dodoc AUTHORS NEWS README doc/TODO
readme.gentoo_create_doc
find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
readme.gentoo_print_elog
if use systemd; then
tmpfiles_process dbus.conf
fi
# Ensure unique id is generated and put it in /etc wrt bug #370451 but symlink
# for DBUS_MACHINE_UUID_FILE (see tools/dbus-launch.c) and reverse
# dependencies with hardcoded paths (although the known ones got fixed already)
# TODO: should be safe to remove at least the ln because of the above tmpfiles_process?
dbus-uuidgen --ensure="${EROOT}"/etc/machine-id
ln -sf "${EPREFIX}"/etc/machine-id "${EROOT}"/var/lib/dbus/machine-id
if [[ ${CHOST} == *-darwin* ]]; then
local plist="org.freedesktop.dbus-session.plist"
elog
elog
elog "For MacOS/Darwin we now ship launchd support for dbus."
elog "This enables autolaunch of dbus at session login and makes"
elog "dbus usable under MacOS/Darwin."
elog
elog "The launchd plist file ${plist} has been"
elog "installed in ${EPREFIX}/Library/LaunchAgents."
elog "For it to be used, you will have to do all of the following:"
elog " + cd ~/Library/LaunchAgents"
elog " + ln -s ${EPREFIX}/Library/LaunchAgents/${plist}"
elog " + logout and log back in"
elog
elog "If your application needs a proper DBUS_SESSION_BUS_ADDRESS"
elog "specified and refused to start otherwise, then export the"
elog "the following to your environment:"
elog " DBUS_SESSION_BUS_ADDRESS=\"launchd:env=DBUS_LAUNCHD_SESSION_BUS_SOCKET\""
fi
}

View File

@ -0,0 +1,13 @@
#!/bin/sh
# launches a session dbus instance
dbuslaunch=$(command -v dbus-launch 2>/dev/null)
if [ -n "$dbuslaunch" ] && [ -x "$dbuslaunch" ] && [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
if [ -n "$command" ]; then
command="$dbuslaunch --exit-with-session $command"
else
eval "$($dbuslaunch --sh-syntax --exit-with-session)"
fi
fi

View File

@ -0,0 +1,65 @@
https://bugs.gentoo.org/653136
From 3c08d28fbae8b0ef3839ef26f8d2a713a9a684f9 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Thu, 21 Feb 2019 23:53:19 +0100
Subject: [PATCH] Make dbus daemon build optional
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -76,6 +76,7 @@ agentdir=$(LAUNCHD_AGENT_DIR)
agent_DATA=org.freedesktop.dbus-session.plist
endif
+if DBUS_DAEMON
if DBUS_BUS_ENABLE_KQUEUE
DIR_WATCH_SOURCE=dir-watch-kqueue.c
else
@@ -230,6 +231,7 @@ EXTRA_DIST += \
tmpfiles.d/dbus.conf.in \
tmpfiles.d/meson.build \
$(NULL)
+endif DBUS_DAEMON
if HAVE_SYSTEMD
systemdsystemunit_DATA = \
--- a/configure.ac
+++ b/configure.ac
@@ -211,6 +211,7 @@ AC_ARG_ENABLE([apparmor],
[enable_apparmor=$enableval],
[enable_apparmor=auto])
AC_ARG_ENABLE(libaudit,AS_HELP_STRING([--enable-libaudit],[build audit daemon support for SELinux]),enable_libaudit=$enableval,enable_libaudit=auto)
+AC_ARG_ENABLE(daemon, AS_HELP_STRING([--enable-daemon],[build with the dbus daemon]),enable_daemon=$enableval,enable_daemon=yes)
AC_ARG_ENABLE(inotify, AS_HELP_STRING([--enable-inotify],[build with inotify support (linux only)]),enable_inotify=$enableval,enable_inotify=auto)
AC_ARG_ENABLE(kqueue, AS_HELP_STRING([--enable-kqueue],[build with kqueue support]),enable_kqueue=$enableval,enable_kqueue=auto)
AC_ARG_ENABLE(console-owner-file, AS_HELP_STRING([--enable-console-owner-file],[enable console owner file]),enable_console_owner_file=$enableval,enable_console_owner_file=auto)
@@ -658,7 +659,20 @@ AC_CHECK_MEMBER([struct unpcbid.unp_pid],
[],
[[#include <sys/un.h>]])
-PKG_CHECK_MODULES([EXPAT], [expat])
+# dbusdaemon checks
+if test x$enable_daemon = xno ; then
+ have_daemon=no
+else
+ have_daemon=yes
+fi
+
+dnl check if daemon shall be built
+if test x$have_daemon = xyes; then
+ AC_DEFINE(DBUS_DAEMON,1,[Use daemon])
+ PKG_CHECK_MODULES([EXPAT], [expat])
+fi
+
+AM_CONDITIONAL(DBUS_DAEMON, test x$have_daemon = xyes)
save_cflags="$CFLAGS"
save_libs="$LIBS"
@@ -1748,6 +1762,7 @@ echo "
Building bus stats API: ${enable_stats}
Building SELinux support: ${have_selinux}
Building AppArmor support: ${have_apparmor}
+ Building daemon: ${have_daemon}
Building inotify support: ${have_inotify}
Building kqueue support: ${have_kqueue}
Building elogind support: ${have_elogind}

View File

@ -0,0 +1,36 @@
#!/sbin/openrc-run
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License, v2 or later
extra_started_commands="reload"
description="An IPC message bus daemon"
pidfile="@rundir@/dbus.pid"
command="/usr/bin/dbus-daemon"
command_args="--system"
dbus_socket="@rundir@/dbus/system_bus_socket"
depend() {
need localmount
after bootmisc
}
start_pre() {
/usr/bin/dbus-uuidgen --ensure=/etc/machine-id
# We need to test if /var/run/dbus exists, since script will fail if it does not
checkpath -q -d "@rundir@/dbus"
}
stop_post() {
[ ! -S "${dbus_socket}" ] || rm -f "${dbus_socket}"
}
reload() {
ebegin "Reloading D-BUS messagebus config"
dbus-send --print-reply --system --type=method_call \
--dest=org.freedesktop.DBus \
/ org.freedesktop.DBus.ReloadConfig > /dev/null
eend $?
}

View File

@ -0,0 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<name>Nedko Arnaudov</name>
<irc><nick>nedko</nick><network>libera.chat</network></irc>
</maintainer>
<maintainer type="project">
<name>LADI project, #ladi on libera.chat</name>
<irc><channel>#ladi</channel><network>libera.chat</network></irc>
</maintainer>
<use>
<flag name="elogind">Use <pkg>sys-auth/elogind</pkg> for session tracking.</flag>
<flag name="systemd">Build with <pkg>sys-apps/systemd</pkg> at_console support</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:freedesktop:dbus</remote-id>
</upstream>
<upstream>
<remote-id type="github">LADI/dbus</remote-id>
</upstream>
</pkgmetadata>