media-sound/jack-keyboard: import from gentoo tree

This commit is contained in:
Nedko Arnaudov 2023-02-19 15:28:34 +02:00
parent 293cd41e3d
commit 2309cb4830
2 changed files with 53 additions and 0 deletions

View File

@ -0,0 +1,10 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d5b7c98..3a9a280 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,4 +68,4 @@ target_link_libraries(jack-keyboard -lm)
install(TARGETS jack-keyboard RUNTIME DESTINATION bin)
install(FILES pixmaps/jack-keyboard.png DESTINATION share/pixmaps)
install(FILES src/jack-keyboard.desktop DESTINATION share/applications)
-install(FILES man/jack-keyboard.1 DESTINATION man/man1)
+install(FILES man/jack-keyboard.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)

View File

@ -0,0 +1,43 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake xdg
DESCRIPTION="A virtual MIDI keyboard for JACK MIDI"
HOMEPAGE="http://pin.if.uz.zgora.pl/~trasz/jack-keyboard/"
SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="lash X"
CDEPEND="
dev-libs/glib:2
virtual/jack
x11-libs/gtk+:2
lash? ( media-sound/lash )
X? ( x11-libs/libX11 )
"
DEPEND="${CDEPEND}"
RDEPEND="${CDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-man.patch"
)
src_prepare() {
cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DJackEnable=ON # though configurable, does not compile withou jack
-DLashEnable=$(usex lash)
-DX11Enable=$(usex X)
)
cmake_src_configure
}