1
Fork 0

app-misc/boxes: drop 2.2.0

Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Closes: https://github.com/gentoo/gentoo/pull/35424
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
This commit is contained in:
Pascal Jäger 2024-02-19 13:32:34 +01:00 committed by Joonas Niilola
parent 16e69985db
commit d7138cf514
No known key found for this signature in database
GPG Key ID: 7383942B8DC06962
3 changed files with 0 additions and 65 deletions

View File

@ -1,3 +1,2 @@
DIST boxes-2.2.0.tar.gz 230099 BLAKE2B 4adb8ddde85cb31f32e98916d5ea2a57afcaa0470f796ba296cb3b80780f158a24b2bc5e9ba923b6a3b35b8f7781cd6ddacd89abadf6f2c07549be7ffe1458f4 SHA512 534d441c34316572d0c7e89f343a3bc5bb5a8466e4d4ed703fb2d14b714f5a6b224f7b0d408525d492da4610f9c5ffd8508e16d98a0781897567fb4aeb316f39
DIST boxes-2.2.1.tar.gz 230900 BLAKE2B 65ab0c8ad52d2764279397135b072bfa6f4bf86e465cc3a4778d30c5b19ce2c0d7c5f8636173529eca92754ee16d38b46a83b067b94315b1ea82448e4b1ac0a8 SHA512 0afa115d5ec01944878ef4d8f33e2887d123b172a0589eda53a04ba671916d9ef1d8299f9df9aeac8989807f86ca1b96b1c34aed03856643a89a07586b82e3b6
DIST boxes-2.3.0.tar.gz 272302 BLAKE2B 282b41aee214f54aa3c8b237bc9f2e48e4144eebd6619880a38c7a71d9bf7bb434a250f29a05f20746530e8458bb0d062cd7e5bea88ebdf64030f090b1a8674a SHA512 d7580462ed5cf8a3299f528d7e4abea1c9733da2823c204bff69a804c72b768c4d3e8505b4d8881aae066f1fd95133cf9dc52e960333a82d8c529f85eb096fb4

View File

@ -1,49 +0,0 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Draw any kind of boxes around your text"
HOMEPAGE="https://boxes.thomasjensen.com/ https://github.com/ascii-boxes/boxes"
SRC_URI="https://github.com/ascii-boxes/boxes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/libpcre2[pcre32]
dev-libs/libunistring:=
"
DEPEND="${RDEPEND}"
BDEPEND="
app-alternatives/yacc
app-alternatives/lex
test? ( app-editors/vim-core )
"
PATCHES=( "${FILESDIR}/${P}-fix-clang16-build.patch" )
src_prepare() {
default
sed \
-e 's:STRIP=true:STRIP=false:g' \
-i src/Makefile || die
}
src_compile() {
emake CC="$(tc-getCC)" CFLAGS_ADDTL="${CFLAGS}" LDFLAGS_ADDTL="${LDFLAGS}"
}
src_install() {
dobin out/boxes
doman doc/boxes.1
insinto /usr/share
newins boxes-config boxes
einstalldocs
}

View File

@ -1,15 +0,0 @@
change function prototype to work with c2x standard. Build fails with clang16 without this
See: https://github.com/ascii-boxes/boxes/issues/106
--- a/src/remove.h
+++ b/src/remove.h
@@ -22,7 +22,7 @@
int remove_box();
-void output_input();
+void output_input(const int trim_only);
#endif /*REMOVE_H*/