1
Fork 0

dev-util/gnome-builder: Fix build against gui-libs/gtk-4.12.5

Closes: https://bugs.gentoo.org/923371
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
This commit is contained in:
Mart Raudsepp 2024-04-15 10:02:13 +03:00
parent 14ac036c44
commit 89550f1ceb
No known key found for this signature in database
GPG Key ID: 10A6C9FA4F499606
2 changed files with 33 additions and 1 deletions

View File

@ -0,0 +1,26 @@
From 43a7c586b7291b5cf82febdaa80b4fe4efea8f54 Mon Sep 17 00:00:00 2001
From: Christian Hergert <chergert@redhat.com>
Date: Mon, 15 Jan 2024 11:54:38 -0800
Subject: [PATCH] libide/tweaks: remove autoptr cleanup
This is not needed now with recent GTK changes merged this morning.
---
src/libide/tweaks/ide-tweaks-window.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/libide/tweaks/ide-tweaks-window.c b/src/libide/tweaks/ide-tweaks-window.c
index f2553a396..dcb55bb35 100644
--- a/src/libide/tweaks/ide-tweaks-window.c
+++ b/src/libide/tweaks/ide-tweaks-window.c
@@ -32,8 +32,6 @@
#include "ide-tweaks-panel-list-private.h"
#include "ide-tweaks-window.h"
-G_DEFINE_AUTOPTR_CLEANUP_FUNC (GtkStackPage, g_object_unref)
-
struct _IdeTweaksWindow
{
AdwWindow parent_instance;
--
2.43.0

View File

@ -31,10 +31,12 @@ REQUIRED_USE="
# Editorconfig needs old pcre, with vte migrating away, might want it optional or ported to pcre2?
# An introspection USE flag of a dep is required if any introspection based language plugin wants to use it (grep for gi.repository). Last full check at 3.28.4
# >=gtk-4.12.5 for relying on GtkStackPage autoptr cleanup added in that version
# TODO: Handle llvm slots via llvm.eclass; see plugins/clang/meson.build
RDEPEND="
>=dev-libs/glib-2.75.0:2
>=gui-libs/gtk-4.8:4[introspection]
>=gui-libs/gtk-4.12.5:4[introspection]
>=gui-libs/libadwaita-1.3.0:1
>=gui-libs/libpanel-1.1.2:1
>=gui-libs/gtksourceview-5.7.2:5[introspection]
@ -126,6 +128,10 @@ that are currently available with packages include:
# stylelint for stylesheet (CSS and co) linting
# gvls for vala language-server integration
PATCHES=(
"${FILESDIR}"/${PV}-fix-gtk-4.12.5-build.patch
)
llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}