1
Fork 0

sci-libs/cartopy: add 0.23.0

Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
This commit is contained in:
Thomas Beierlein 2024-04-18 20:26:07 +02:00
parent f1987974f3
commit 232ab0fd0c
No known key found for this signature in database
GPG Key ID: AF4C8CF6B6C40570
3 changed files with 101 additions and 0 deletions

View File

@ -1,2 +1,3 @@
DIST cartopy-0.21.1.gh.tar.gz 10815884 BLAKE2B 4137f593b6ce35270f9df5016529250a07c57ec5a95843db8740eb494f55109b5129cf72153b0216e4f786771bf5cedde3caaecd40175fe9ad5c6fb65ad84788 SHA512 de1d09ee3bf6af13bcc7cc4bb1f7c13335ba67e05d2ad64efa0fb00bdb74c7e13c6fc44822d5ac1d70ee7d39b2322280c1395dc66119b9ecd94ca26014e413a1
DIST cartopy-0.22.0.gh.tar.gz 10907762 BLAKE2B 0524efb2359f72da4e73cc74c41b03f4e335163dea4b86f5b8907b2a20521ce81a42fceebbdd7e582315b33aed0dfdf159469dfa13516c9c46a8f887f847fa21 SHA512 195cc69170c826240e03918de39925459c94c36b76f1a87b8ec3bca7c00ed577eb8c727ccda1511c0f691ac5aea043d3d02d7bfb603624548e63c9a7dc644ad5
DIST cartopy-0.23.0.gh.tar.gz 10645484 BLAKE2B aa9306e9f5bd85ae28be4802aac1a36d67df5812e9d188ad20d27103eaff1856b7d48e256459519b4e647bdf17fc207e8473ec6ead7413db113311fe821faba6 SHA512 8f357faad592db03c564d2c87f6d1600d2a04a68b71b250925c222cea418b8588f2eb48f64d3ec7210650a34372777ef8416c8f129af7911661615759d2c60b5

View File

@ -0,0 +1,87 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_EXT=1
PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 multiprocessing virtualx
MY_PV=${PV/_beta/b}
MY_P=${PN}-${MY_PV}
DESCRIPTION="Python package for geospatial data processing and analysis"
HOMEPAGE="https://scitools.org.uk/cartopy"
SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}"/${MY_P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
sci-libs/gdal[python,${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/numpy-1.19[${PYTHON_USEDEP}]
dev-python/shapely[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/pillow[jpeg,${PYTHON_USEDEP}]
dev-python/pyproj[${PYTHON_USEDEP}]
sci-libs/pyshp[${PYTHON_USEDEP}]
')
"
DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_cond_dep '
dev-python/setuptools-scm[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
')
test? (
$(python_gen_cond_dep '
dev-python/filelock[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/flufl-lock[${PYTHON_USEDEP}]
dev-python/pytest-mpl[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
')
)
"
PATCHES=(
"${FILESDIR}"/${P}-backport-test-fixes.patch
)
EPYTEST_IGNORE=(
# Require network access, not covered by markers
lib/cartopy/tests/mpl/test_crs.py
lib/cartopy/tests/mpl/test_gridliner.py
)
distutils_enable_tests pytest
python_prepare_all() {
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
# Prepare matplotlib backend for test suite
export MPLCONFIGDIR="${T}"
echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
sed -i -e "s/exclude =/#exclude =/" pyproject.toml || die
distutils-r1_python_prepare_all
}
python_test() {
cd "${BUILD_DIR}" || die
# Drop all tests needing network access
virtx epytest -n "$(makeopts_jobs)" -m "not network and not natural_earth" || die "test failed"
}

View File

@ -0,0 +1,13 @@
# backport last test fix just after v0.23 release
diff --git a/lib/cartopy/tests/mpl/test_gridliner.py b/lib/cartopy/tests/mpl/test_gridliner.py
index 7d82178..d07573e 100644
--- a/lib/cartopy/tests/mpl/test_gridliner.py
+++ b/lib/cartopy/tests/mpl/test_gridliner.py
@@ -496,6 +496,7 @@ def test_gridliner_count_draws():
mocked.assert_called_once()
+@pytest.mark.natural_earth
@pytest.mark.mpl_image_compare(
baseline_dir='baseline_images/mpl/test_mpl_integration',
filename='simple_global.png')